PPM インストールツール(2019/07/13)


ActivePerl, Strawberry Perl 用の PPM インストールツールをブルー会員エリアに置きました。

Perl 5.30/5.28/5.26/5.24/5.18/5.16 用の 6 バージョンです。いずれも x64 版にのみ対応しています。(5.30/5.28 は StrawberryPerl のみ対応)

Namazu for Windows のバイナリパッケージには、特定の Perl バージョンのPPMをインストールするための ppm-inst.bat, ext-inst.bat が付属しています。 本 PPM インストールツールを Namazu for Windows 付属の ppm-inst.bat, ext-inst.bat に置き換えて使用することで、それぞれの Perl バージョンの PPM をインストールすることができます。

  • Strawberry Perl 5.30

https://www.akaneiro.jp/members/blue/ppm-inst-3000.zip

※ Namazu for Windows 2.0.22pre8 以降が対象

 

  • Strawberry Perl 5.28

https://www.akaneiro.jp/members/blue/ppm-inst-2800.zip

※ Namazu for Windows 2.0.22pre8 以降が対象

 

  • ActivePerl 5.26/Strawberry Perl 5.26

https://www.akaneiro.jp/members/blue/ppm-inst-2600.zip

※ Namazu for Windows 2.0.22pre7 以降が対象

 

  • ActivePerl 5.24/Strawberry Perl 5.24

https://www.akaneiro.jp/members/blue/ppm-inst-2400.zip

 

  • ActivePerl 5.18/Strawberry Perl 5.18

https://www.akaneiro.jp/members/blue/ppm-inst-1800.zip

 

  • ActivePerl 5.16/Strawberry Perl 5.16

https://www.akaneiro.jp/members/blue/ppm-inst-1600.zip

 

なお、本 PPM インストールツールを使用する際には、ブルー会員ユーザID/パスワードが必要になります。

 

 

http://www.activestate.com/activeperl/downloads

http://strawberryperl.com/releases.html

 

注意:

  • 本 PPM インストールツールを使用せず、手動でもインストールできる PPM はあります。(本 PPM インストールツールを使用しないとインストールできない PPM もあります。)
  • ブルー会員エリア以外でも公開している PPM があります。(ブルー会員でなくても手動でインストールできるPPMはあります。)
  • 予告なく PPM の公開範囲を変更することがあります。